We’re pleased to inform you that the service disruption affecting the CureMD application has been fully resolved. The issue originated from a global Cloudflare outage, which has now been addressed by Cloudflare.
All CureMD services are operating normally.
We appreciate your patience and understanding during this incident, and thank you for your continued trust in CureMD.
Kind regards, CureMD Incident Management Team
Posted Nov 19, 2025 - 19:44 UTC
Update
Dear CureMD User,
We’re pleased to inform you that most CureMD services are now operational. However, you may still experience intermittent disruptions with certain partner-dependent features, such as Telemedicine and eRx, due to ongoing effects from the Cloudflare outage.
Our teams continue to monitor system stability closely and are coordinating with partners to ensure full restoration as soon as possible.
Thank you for your continued patience and understanding.
CureMD Incident Management Team
Posted Nov 18, 2025 - 20:23 UTC
Update
Dear CureMD User,
Cloudflare has acknowledged the issue and is working toward full resolution.
We appreciate your patience and understanding as we continue to work toward restoring normal service as quickly as possible.
CureMD Incident Management Team
Posted Nov 18, 2025 - 16:16 UTC
Monitoring
Dear CureMD User,
This is to inform you of a service disruption affecting the CureMD application. This issue is the result of a widespread global outage with Cloudflare, a provider of critical internet infrastructure, which is impacting numerous online services worldwide.
Our technical team is actively engaged and has implemented our contingency plans to minimize the impact on your operations. We are closely monitoring the situation and will provide updates as we have them.
We understand how critical uninterrupted access is for healthcare delivery and apologize for the significant inconvenience this causes. Our absolute priority is restoring full service stability as quickly as possible.