Users may experience difficulty signing superbills.

Incident Report for CureMD

Resolved

Dear Valued Customers,

We are pleased to inform you that the superbill signing issue is fully resolved. You should now experience a seamless user experience.

We apologize for any inconvenience this may have caused and appreciate your patience and understanding during this time. Thank you for your continued support.

If you have any further questions or need assistance, please don't hesitate to reach out.

Best regards,
CureMD Incident Management Team
Posted Jul 18, 2024 - 16:10 UTC

Monitoring

Dear Users,

We are currently experiencing an issue with signing superbills using CureMD 10g. Our development teams are actively working to resolve this as quickly as possible. We apologize for any inconvenience this may cause and appreciate your patience.

Thank you for your understanding.

Regards,
CureMD Incident Management Team
Posted Jul 18, 2024 - 16:05 UTC
This incident affected: Superbill.