Patient Eligibility Verification Service Interruption

Incident Report for CureMD

Resolved

Good news—insurance eligibility look-ups are working normally again. Our clearing-house partner has resolved the upstream issue that caused this morning’s interruption, and eligibility responses are now flowing as expected.

We’re keeping an eye on performance and have not seen any further anomalies.

Thank you for your patience while this was sorted out.

Regards,
Incident Management Team
CureMD
Posted Jul 08, 2025 - 15:56 UTC

Monitoring

A few practices are having trouble running insurance eligibility checks right now. Our platform remains fully operational, but eligibility responses are delayed or unavailable while the partner works to restore service.

We’re in close contact with their engineering team and will share updates here every hour—or sooner if we learn more.

Thank you for your patience. If you need any help in the meantime, please reach out to Support and we’ll do our best to assist.

Regards,
Incident Management Team
CureMD
Posted Jul 08, 2025 - 15:17 UTC
This incident affected: Patient Insurance Eligibility.